Home > Linuxでハマる > Nessus のプラグインのアップデートができない?

Nessus のプラグインのアップデートができない?

仕事上、サーバ類のセキュリティホールチェック(ペネトレーションテストとも言うのかな?)にNessusを使っている。

久しぶりにNessusを使おうと思い、まずはプラグインを最新化しなくっちゃ、と下記コマンドを実施。

nessus-update-plugins

すると、次のようなエラーが表示され、プラグインのアップデートができない。

An unknown HTTP error occured (http error code: 404)
E: Could not retrieve the plugins MD5

Aborting

なんだかんだやってみたのだが、時間もなかったので最新バージョンを再インストールすることにした。

が、Nessusのサイトで最新版(3.2.0)をダウンロードしようとしたのだが...

Vine用がない。

Linux用は Fedora 7, 8, Red Hat EL 3, 4, 5, CentOS 3, 4, 5, SuSE 9.3, 10, Debian 4, Ubuntu 7.10 しかない。
全部.rpmや.debの形式になっている。
前のバージョンのようにShellでインストールできる形式じゃないのね。

というわけで、バージョン2.2.11をインストールすることにした(バージョン2まではShellを実行してインストールする方式なので、VineでもインストールOK)。

で、nessus-installer-2.2.11.sh に実行権限を追加して実行。

すると、途中で

If you already registerd and received an activation code. please enter
it below if you want to activate it now :

Activation code :

と聞いてきた。
そういえば、昔Nessusのアクティベーション・コードを取得したなぁ、と思い出し、昔のメールを引っ掻き回したところ見つけましたょ、アクティベーション・コード。

そのメールには、

To activate your account, simply execute the following command :
nessus-fetch --register XXXX-XXXX-XXXX-XXXX-XXXX

と書いてあった。

再インストールしなくても、まずは「nessus-fetch –register」コマンドを実行すれば良かったのですね。

とりあえず、Nessus 2.2.11 を正常にインストール終了し、改めて「nessus-update-plugins」を実行したところ、問題なく終了した。

やれやれ、またハマってしまった。

Comments:0

Comment Form
Remember personal info

Trackbacks:0

Trackback URL for this entry
http://www.nozuchi.net/oike/wp-trackback.php?p=15
Listed below are links to weblogs that reference
Nessus のプラグインのアップデートができない? from お池にハマってさあ大変

Home > Linuxでハマる > Nessus のプラグインのアップデートができない?

Calendar
« 2018 年 11月 »
S M T W T F S
        1 2 3
4 5 6 7 8 9 10
11 12 13 14 15 16 17
18 19 20 21 22 23 24
25 26 27 28 29 30  
最近の投稿
 

Return to page top